05日 2009年09月

Linux 下蓝牙耳机没有声音简单交流

-- 转载请注明出处 http://www.zzzke.cn/ 或超链接至本文 --

    Linux 下蓝牙耳机使用本来就不易,关于使用方法详见本站文档 Ubuntu Linux 下蓝牙耳机使用 ,在 Ubuntu 及 Debian Linux 下使用蓝牙耳机还需注意的一点就是系统中安装的 bluez 版本与 pulse 版本是否符合 bluez 已安装版本的要求,bluez 与 pulse 版本的对应列表如下:

  1. bluez 4.27-33:  pulse 0.9.14 
  2. bluez 4.34-38:  pulse 0.9.15 
  3. bluez 4.39+:    暂不详 

    你可以到 新立得软件包管理器(下而将以 新立得 称) 中搜索查看已经安装的 bluez 及 pulse 版本,如下 2 图:

    可以从上面二图中看到,bluez 已安装版本为 4.39 ,而 pulse 已安装版本为 0.9.14 ,并且均已经是软件库中的最新版本了。对照上表可得出bluez 4.39 与 pulse 0.9.14 是不对应的,也就是说二者可能无法携同工作。解决的方法有二种,一是自行到 PulseAudio 网站 下载能支持 bluez 4.39 的 pulse 版本将 pulse 升级更新至 bluez 支持的版本,二是将 bluez 降至 4.27 - 33 版本并且 pulse 0.9.14 保持不变动。在这里就以能在 新立得 中操作的第二种方法为例子图解一下软件包降级版本方法,首先在 新立得 中搜索已安装的所有 4.39 版本的 bluez 相关包,再将菜单栏的 软件包 -> 强制版本... 打开,如图:

    点击后选择支持 pulse 0.9.14 的 bluez 历史版本,如下图:

    从上图中可以看到 bluez 强制版本 中有 4.32 版是可与 pulse 0.9.14 版携同工作的,但 4.32 又有 2 个不同的可用版本,在此任选一个版本均可,选择完成点击 强制版本 按钮即可,并依次将所有的 bluez 相关 4.39 版本强制成你所选择的同一个 4.32 版本。如下图:

    然后点击 新立得 中的 应用 来应用强制,如下图:

    确认应用变更列表并执行应用。

    应用执行完成后退出 新立得 即可,在 退出 时可能会有如上图对话框,因为降级应用后 新立得 还会默认标记升级,出现此对话框后只要点击退出即可完成。完成后再次在 新立得 搜索 bluez 后所有 bluez 4.39 已安装版本将变成如下图的 4.32 版本。

    所有的 bluez 与 pulse 版本匹配操作已经介绍完了,如果你也有此类版本不匹配问题希望此文对你会有帮助,在按此图解正确变更完成后别忘记了重启你的电脑,重新与你的蓝牙耳机配对并设置为将声音传输至你的蓝牙耳机后是不是可以听到蓝牙耳机中能正常听到声音了呢...

    最后再提示一下,因为降级后的版本不是软件库中的最新版本了,所以系统的 更新管理器 在每检查更新的时候都会检查到你的 bluez 及相关包有更新,如下图:

    你要在每一次更新时去掉 bluez 及相关更新包提示前的钩,这样在每次更新时就会跳过这些包,直到有与 bluez 相匹配的 pulse 更新版本的时候同时更新,否则更新后又会出现已安装的 bluez 与 pulse 版本不匹配问题。

推荐文档

02 May 2014

Donec id elit non mi porta gravida at eget metus amet int

02 May 2014

Donec id elit non mi porta gravida at eget metus amet int

02 May 2014

Donec id elit non mi porta gravida at eget metus amet int